Somebody knows... Maybe you?
ls14garlo
Posts: 75
Joined: Sat Jun 25, 2016 4:22 am

Jackpot (no) Joy!

Postby ls14garlo » Sat Oct 29, 2016 10:09 am

:!?!: Hello mechanical marvel experts, another one to tax your extensive knowledge banks.....
This is hopefully my last problem concerning something that's not quite right on my Bonanza Star. I saved the best till last !!THUMBSX2!!
After some extensive research through past posts about Mills/Sega jackpots not working I'm almost certain I have the complete package for a working jackpot... but it doesn't! (or rather always does). I've got some photos of the mechanism side of it and the actual jackpot itself for you to peruse, missing springs or upside down levers? The problem is I think I'm resetting it right, with the trapdoor closed but as soon as I insert the mechanism and pull once it fires, leaving the trapdoor permanently open? !PUZZLED! I'd like it to work correctly obviously for authenticity (and value!) but I wouldn't mind too much if it would just stay closed so I can fill it and it stays full...
I'm probably missing something but I don't know what it should look like as a working jackpot so any help, maybe spot a missing spring or something would be greatly appreciated.... Cheers guys!! !WORSHIPFULL!
DSC_2029a.jpg
DSC_2031a.jpg
DSC_2032a.jpg
DSC_2033a.jpg
DSC_2035a.jpg
DSC_2036a.jpg
DSC_2037a.jpg
DSC_2038a.jpg
DSC_2039a.jpg
DSC_2040a.jpg

User avatar
coppinpr
Posts: 3641
Joined: Sun Oct 10, 2010 2:01 pm
Location: Lewes, East Sussex
Contact:

Re: Jackpot(no)Joy!

Postby coppinpr » Sat Oct 29, 2016 11:16 am

It's not easy without the jackpot in hand. First thing to work out is = is it the jackpot unit or is it the mech side? Most likely it's the JP.

So you're saying it locks fine when you work it manually out side the case and fires OK by hand? But fires every play (or every win)? then won't reset in the case?

If all the above line is true then it would hint at the connections between the mech and the unit. Are you sure you have all the parts of the reset bar and that it moves forward every time,engaging the jp unit if the trap is open? Are you sure the top payout slide is resetting during the cycle and NOT firing forward on every play?

If you are sure about all parts of the above section then its not the mech connections on the mech side.

If it's the unit, we need to move forward a bit at a time. Do you have the pictorial guide to Mills machines? If no, I can photo copy the JP exploded view and you can check (a) it's all there and (b) everything is in the right place. Looking at the unit outside the case does it appear the knob on the top slide would hit the release on the unit correctly? and the same for the reset?

A side view of the unit would be helpful.

Check these points out and let us know.

ls14garlo
Posts: 75
Joined: Sat Jun 25, 2016 4:22 am

Re: Jackpot (no) Joy!

Postby ls14garlo » Mon Oct 31, 2016 8:37 am

!THUMBS!
Thanks for your advice Coppinpr, I don't have the Mills pictorial so a scanned image of the page in question would be appreciated!!
After your advice, I double checked any previous posts on here aswell as a Google image search and it does look like there's a large lever missing.....
On my jackpot there's a large bracket about a third down from the top,bottom picture it's visible(I thought the hole was for a spring to hook onto). Looking at the few photos there are of that part of the jackpot,there should be a large lever fastened to it, possibly the coupling from the mechanism?
I've took a couple of photos of it out of the machine so you can get a clear picture of what's not there!
Is it worth my while trying to sort it out(I've read they can be a lot of hassle) or just remove a couple of springs to keep it closed? Cheers again!!
DSC_2053a.jpg
DSC_2052a.jpg
DSC_2043a.jpg

User avatar
badpenny
Forum Moderator
Posts: 5868
Joined: Thu May 05, 2005 12:41 pm
Location: West Midlands
Contact:

Re: Jackpot (no) Joy!

Postby badpenny » Sun Jan 01, 2017 12:02 pm

Is this the post you're still searching a solution for?

If it's still doing it......
Remove the mech from the case and slacken off the bolts holding the baseplate in place.
Next slide the baseplate forward towards the front of the case a few mm.
Tighten everything up, replace the mech and try that.

It sounds to me as if the slides aren't reaching the point of pushing the JP reset lever where it locks, so the moment the cycle runs back and allows the slides to sit back against the stop, the JP fires.

BP

ls14garlo
Posts: 75
Joined: Sat Jun 25, 2016 4:22 am

Re: Jackpot (no) Joy!

Postby ls14garlo » Sun Jan 01, 2017 7:16 pm

Yes Bp, this is the one, I took the jackpot unit out a couple of months ago, it's still sitting in a cupboard in the kitchen....I'd almost given up!! I'll have a tinker with it when I get chance, once that's sorted I'll be really made up with it after so long messing with all the little niggles....Is that really all there is to it, literally just down to positioning? I've almost convinced myself there's something missing :!?!:
Thanks Bp,I'll put a word or two up when I've had a look!!

User avatar
badpenny
Forum Moderator
Posts: 5868
Joined: Thu May 05, 2005 12:41 pm
Location: West Midlands
Contact:

Re: Jackpot (no) Joy!

Postby badpenny » Mon Jan 02, 2017 1:34 am

Now you've said that I'm even more convinced it's down to positioning ..... there's no way it's going to work with the jackpot bank in a cupboard in the kitchen. Cupboard under the stairs maybe, behind the clock on your mantelpiece would be fine, but never in the kitchen cupboard. :o

ls14garlo
Posts: 75
Joined: Sat Jun 25, 2016 4:22 am

Re: Jackpot (no) Joy!

Postby ls14garlo » Mon Jan 02, 2017 4:46 am

:HaHa:
That's it then, problem solved- it's a good 45 feet from there to where the machine is!! :oops:


Who is online

Users browsing this forum: No registered users and 4 guests